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1. Revision History 
 
  

Revision Date Author Description 
A 08/07/2009 Radio Dispatch Engineering Group Initial draft C-Soft Version 4.200 
B 09/11/2009 Radio Dispatch Engineering Group Updated to  C-Soft Version 4.300 
C 03/31/2010 Radio Dispatch Engineering Group Updated to  C-Soft Version 5.000 
D 06/24/2010 Radio Dispatch Engineering Group Updated to  C-Soft Version 5.100 
E 07/16/2010 Radio Dispatch Engineering Group Updated to  C-Soft Version 5.200 
F 10/22/2010 Radio Dispatch Engineering Group Updated to  C-Soft Version 5.300 
G 05/26/2011 Radio Dispatch Engineering Group Updated to  C-Soft Version 5.400 
08 06/08/2012 Radio Dispatch Engineering Group Updated to  C-Soft Version 6.000 
09 07/26/2012 Radio Dispatch Engineering Group Updated to  C-Soft Version 6.100 
10 12/06/2012 Radio Dispatch Engineering Group Updated to  C-Soft Version 6.200 
11 08/20/2014 Radio Dispatch Engineering Group Updated to  C-Soft Version 6.500 

 
 

2. Overview 
This is the release notes for C-Soft Version 6.500 firmware/software. This release contains new features, 
improved features, and fixed issues.  The release notes include all of the changes and fixes since official 
release Version 6.200. 
 
 
3. New Features 

Version 6.500 
 C-Soft Designer 

 General 
 Added ability to horizontally and vertically center a group of buttons. 
 File Information Window  

 Located in File -> File Information and displays the following information: 
o File path of current .veg file 
o Version of C-Soft Designer used to last save the .veg file 
o Total number of buttons 
o Total number of popup windows 
o Total number of sliders 

 
 New UI Controls 

 Dial Button – Button which will dial the DTMF digits specified as the destination in 
the keypad module. 

 Event Logger Button – Window in C-Soft Runtime which displays the messages 
being logged to the System Log file.  The Event Logger window uses the logging 
level set in Edit -> Edit Global Parameters -> Control Settings.  Currently, log 
messages are only generated for events pertaining to the Sprint Direct Connect 
interface. 

 Keypad – Used to select a destination address for radio operations. 
 Destination addresses can be selected either from a contact list or manually 

entered from a dial pad interface. 
 The following radio operations are supported: 

o Dial, Radio Check, Radio Enable, Radio Disable, Call Alert, Select 
Call, Remote Monitor, Status Request, Status Message, GPS 
Operations, Private PTT, and Group PTT 
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 The keypad’s appearance can be customized in C-Soft Designer.  
 Keypad module includes contains the following pages:  

o Contact page (displays Filters, searchable contact list) 
o Manual Page (shows on-screen keypad),  
o History page (shows list of previous operations).   

 For more information on how to set up and use the keypad module please 
refer to the C-Soft Keypad Module Application Notes.  

 Page Cancel Button – Button which will cancel any outgoing pages when clicked. 
 Radio Status Button – Radio command button which supports sending a status to 

a specified user.  The Radio Status button can be configured to either a single 
dedicated status, or to present a configured list of statuses to the user in Runtime.   

 Select Call Button – Radio command button which supports sending a select call to 
a destination selected from the keypad (if present), or from a dropdown list. 

 
  C-Soft Runtime  

 Interfaces 
 MOTOTRBO Interface – Added support for new MOTOTRBO Interface to work with 

the IP-224.  For information on how to set up and use MOTOTRBO Interface in C-
Soft, refer to the MOTOTRBO Interface Application Guide document. 

 Sprint Direct Connect Interface - Added support for Sprint Direct Connect 
interface.  For information on how to setup and use Sprint Direct Connect in C-Soft 
refer to the Sprint Direct Connect Application Guide document. 

 
 

4. Improved Features and Fixed Issues 
Version 6.500 
 C-Soft Designer 

 Annunciation 
 Added the following features to the Annunciation button’s property page: 

 Frequency: assigns a frequency in which to send the annunciation.  
Previously, the annunciation was sent on the currently selected frequency. 

 Stay Selected After Annunciation: if checked, the sending line remains 
selected after the Annunciation is complete. 

 Activate Relay With Annunciation: if checked, automatically triggers a 
relay while the annunciation is being sent, using the specified Relay Setup 
settings. 

 
 Data Validation 

 Added text length validation to fields in the AutoFill window 
 Changed the minimum allowed value for the Phone Ring and NEO-10 Update Port 

fields in Global Parameter Setups->Peripherals from 0 to 1054. 
 Fixed issue where invalid parameters in the UI Element Setup windows would 

generate multiple duplicate error messages. 
 In Per Line SIP Setup window, added validation of Address of Record and Realm 

text fields. 
 In Per Line window, added validation to ensure the Packet Delay field is within the 

valid range. 
 In User ID and Group ID lists, resolved issue where sorting was causing unsaved 

entries to disappear. 
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 In the UI Element Setup windows, fixed issue in which invalid data could be saved to 
the .veg file after either clicking the window Close button (X button) or pressing the 
ESC key after the Invalid Data window was displayed.   
 

 Frequency Control 
 Changed the allowed range of the Arrow Button size to allow for a button size of 0.  

When the button size is zero, the arrow buttons will be hidden.   
 

 Filter List 
 Increased the maximum number of filters supported in the filter setup from 30 to 60. 

 
 General 

 Re-ordered the menu items in the Insert menu so they are in alphabetical order. 
 The Up and Down bitmaps fields in the Colors tab are no longer read only.  These 

two text fields can now be edited directly by the user. 
 Fixed issues with drawing UI elements so moving, resizing, and rotating text and 

frames no longer leaves artifacts. 
 Buttons placed within a frame, or on top of a background logo image will now draw 

correctly. 
 Fixed a bug where the Run feature would not use the correct user-configured 

CSoftRuntime.exe file path after C-Soft Designer was closed and re-opened. 
 Standardized the name, location, and behavior of standard dialog window buttons 

where possible (i.e. OK, Cancel buttons). 
 

 Global Parameters 
 Always Display Unit # – Located in Edit -> Edit Global Parameters -> Appearance.  

When checked, the numeric ID of the incoming caller will always be displayed on the 
line’s Select button, even if the user ID has an alias in the User ID List.  The Unit’s 
number will be displayed beneath the unit’s alias, if available, on the Select button. 

 Hide Group ANI – Located in Edit -> Edit Global Parameters -> Appearance, this 
field, when checked, will no longer display incoming Group ANI information on the 
line’s Select button.  Currently only affects Sprint Direct Connect Interface, iDEN, 
and P25-DFSI lines. 

 System Log File - Setting located in Edit->Global Parameters -> Control Settings.  
Currently, log messages are only generated for events pertaining to the Sprint Direct 
Connect interface.  If enabled, the console will write various log messages to a file is 
created in one of two locations depending on the PC’s operating system. 

 Windows XP:   C:\Documents and Settings\All Users\Application Data\Telex 
Communications\logs_folder 

 Windows 7:   C:\ProgramData\Telex Communications\logs_folder 
 The log file is named SystemLog_XXX_YYY.txt where XXX is the date and 

time stamp and YYY is the name of the .veg file.   
 SOIP PTT Hanger Timer – Located in Edit -> Edit Global Parameters -> Audio, this 

field delays the PTT off command for SOIP protocols by the time value entered.  
Currently only affects Sprint Direct Connect Interface lines.  The delay allows the IP-
22X to complete processing any transmit audio before C-Soft sends a command to 
the serial device to stop transmitting.  This following equation should be used to 
calculate the Hang Timer Delay: 

 Hang Timer Delay = IP-224 Packet Delay * 20 ms + IP-224 TX Delay 
 On Audio page, renamed Disable Local iDEN Tones field to Disable Local Talk 

Permit Tones. 
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 Group ID List 
 Added ability to sort Group ID List by Name or ID. 

 
 Input Indication 

 Blink for __ seconds: When checked, upon input change, the Input Indication 
button will flash for the specified number of settings. 

 Activate Relay With Input: When checked, input change will automatically trigger a 
relay and/or flash the Input Indication button using the specified settings. 

 
 NENA 

 Re-named all UI elements that interact with NENA and AHDB-4 from NENA to 
AHDB-4 NENA.  The UI elements were renamed to indicate they only function when 
using an AHDB-4 and not any other device.   

 UI Elements renamed include: 
o NENA Hold is now AHDB-4 NENA Hold 
o NENA Hook Control is now AHDB-4 NENA Hook Control 
o NENA Indication is now AHDB-4 NENA Indication 
o NENA Mute is now AHDB-4 NENA Mute 
o Volume NENA is now Volume AHDB-4 NENA 

 
 NEO-10 Setup  

 Fixed issue where the NEO-10 IP Address field in Input Indication setup would be 
disabled even if NEO-10 was selected as the Input Source. 
 

 Paging 
 Added the Inter Page Delay field to the individual Pager and Manual Page Setup.  

The Inter Page Delay field is used to insert a delay between stacked pages. 
 Fixed issue which caused the Initial Page Delay to always be at least 800 ms. 
 Renamed the Pager Setup window (Edit -> Setup Pagers) window to Paging 

Settings. 
 Moved the following fields from Global Parameters -> Control Settings to the Paging 

Setting window: 
 Always Stack Pages 
 Stack Programmable Page Stack buttons 
 Page Freq Revert 

 Renamed the following fields in Paging Settings window, to clarify behavior: 
 Always Stack Pages is now Always Stack page buttons 
 Stack Programmable Page Stack buttons is now Allow Programmed Page 

Stack buttons to be stacked 
 Inter Page Delay is now Delay Between Stacked Pages. 
 Page Freq Revert is now Revert to initial frequency after sending page 
 The Send Sequentially checkbox is now a radio button group with a group 

box name of Page Send Topology and with the options of Sequential and 
Parallel 

 Added the Manually confirm pages are done sending checkbox to the Paging 
Settings window.  When checked, Page, Manual Page, and Programmed Page 
Stack buttons will display the Done icon once all pages generated by a page button 
have been sent by the console.  The Done icon remains visible on the page buttons 
until the Page Cancel button is pressed. 

 Added ability to automatically trigger a relay when sending out a Page. 
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 MOTOTRBO 
 Up to 10 icons can now be associated with a MOTOTRBO ID in the User ID List 

setup, these icons will show up on Google Earth.  These icons are located at 
“\Program Files\Telex Communications\C-Soft\GoogleEarth\icons”. 

 Removed button configuration options for the Emergency Acknowledge and Alert 
Cancel buttons located in the History tab.  These buttons was removed from the 
Runtime window. 
 

 P25-DFSI Window Setup 
 Removed button configuration options for the Emergency Acknowledge button 

located in the History tab as the button was removed from the Runtime window. 
 

 Popup Setup  
  Added "Automatically close children popup windows" check box in Popup 

Window Setup.  When checked, closing a Popup window will automatically close 
any children popup windows which are open.  When unchecked, the children popup 
windows will remain open after the parent window has been closed.  

 SIP 
 Renamed fields in SIP Setup Dialog to make setup more intuitive. 
 Added Display Missed Call Notifications checkbox to SIP Call Control setup page.  

When checked, the SIP Call control will display missed call notifications otherwise, 
no notifications are shown.   

 Added a user-configurable setting for the SIP Window’s text color to the SIP Call 
Control setup page. 

 Added ability to answer incoming call with one click if SIP Window is closed.  Option 
is named Answer Calls on SIP Control Click and is located in the SIP Call Control 
setup page. 
 

 Signaling Setup 
 Display All Calls setting is now disabled for certain signaling types where the setting 

is not used or irrelevant. 
 

 System List 
 Renamed the System type "Kenwood-Serial" to "Telex Serial" for standardization 

with IP-224. 
 Fixed bug in which the System List would become corrupted if the '(' character was 

present in a User ID, Group ID, Status, or Text Message alias. 
 Improved the load time of the System List in the System List Edit System window for 

large (1000+ entry) systems. 
 

 UI Element Configuration 
 Added the ability to double click on any UI Element to open the element’s Setup 

dialog. 
 Fixed a bug involving Text UI elements initially displaying text with an incorrect font 

size.  A smaller font size was incorrectly being used to draw the Text element than 
was selected in the Font setup dialog. 

 The Selection/Focus rectangle is now correctly sized when selecting a text control in 
a popup window. 

 Clicking the Frame Setup window's "Use Bitmap" button no longer automatically sets 
the Border Width to 40. 

 Remote Monitor button is now correctly initialized when using either the 
MOTOTRBO or P25-DFSI filter in UI Element Setup. 
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 User ID List 
 The maximum number of User IDs supported by the User ID List from 5000 to 6000. 
 Added ability to sort the User ID by either Name or ID. 
 Fixed bug where importing a User List created in a previous version of C-Soft 

Designer would cause Designer to crash. 
 

 C-Soft Runtime  
 ADHB-4 

 Audio is no longer routed to the Unselect Speaker if the HB3+ headset switch or 
ADHB-4 headset is in the On position. 

 Console error tones audio is now correctly from the ADBH-4. 
 Fixed bug where if an ADHB-4 was connected to the PC while C-Soft Runtime was 

running, the first key up of a Spacebar PTT would not be recognized.  The error 
would occur only if the .veg file did not contain IRR buttons or a Global Call History 
window and no lines were selected when Runtime was started.  
 

 Cposi.txt 
 The location of the P25-DFSI and MOTOTRBO windows are now saved in the 

cposi.txt file  
 Improved how the MOTOTRBO and P25-DFSI call entry information is stored to 

prevent the corruption of the cposi.txt file.  A corrupt cposi.txt file can cause C-Soft 
Runtime to crash on the next boot-up.  
 

 Fleetsync Window 
 Fixed various bugs where certain radio commands were not being added to the 

History tab in the Fleetsync history window. 
 

 Frequency Control 
 While Scan mode is active, the Scan List can no longer be modified.  
 Resolved issue where when clicking and holding on the scroll bar with the mouse 

the list of items stops scrolling, but the scroll bar slider isn’t located at the minimum 
or maximum range of the scrollbar. 
 

 General 
 Added logic to prevent the selected line(s) from changing during a Main PTT press. 
 Fixed issue where if Line #1’s Packet Delay was greater than 29, no audio would be 

played back from the console. 
 Encryption and Talk Around buttons are now updated based on information sent 

back from the IP-224. 
 Emergencies will now only be displayed (e.g. play emergency alert tones and blink 

Select button) if either an Emergency Ack button is configured for the line receiving 
the emergency or an Active Emergency Window is present in the .veg file.   

 Fixed issue which improved the accuracy of time based operations (i.e. Page Talk 
Time, Mute Time, RX Block Timeout, etc) in C-Soft Runtime.  In previous versions of 
C-Soft, timed operations were approximately 10 – 20% slower than the configured 
time.   

 Improved support for third party packets which are used to trigger Emergencies and 
other radio command operation in C-Soft Runtime. 

 Fixed issued which would cause C-Soft to show the RX audio indication icon and log 
calls to the Per Line Call History when receiving channel updates. 
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 Global Call History  
 Fixed issue where the same incoming call from an IP-224 would generate multiple 

entries in the Global Cal History window. 
 

 MDC-1200 
 The Calling ID field is now properly populated when receiving a Select Call sent to a 

Group when using an IP-224. 
 The MDC-1200 Window now displays individual units.  Before only units in a filter 

were being displayed. 
 

 MOTOTRBO 
 Added support to automatically clear call alerts from the mobile radio as soon as the 

call alert is received.  This prevents the mobile radio from blocking subsequent 
incoming call alerts. 

 Added support to acknowledge call alerts and clear emergencies indications from 
the mobile radio when using an MTRBi and Motorola XPR 5550 mobile radio. 

 C-Soft now properly clears the emergency indications from the mobile radios in the 
case of multiple simultaneous emergencies on MOTORBO Interface and MTRBi 
lines. 

 Removed the Emergency Acknowledge and Alert Cancel buttons from the 
MOTOTRBO Window’s History tab. 

 Clicking the Active Emergency window's Clear button will now clear and not 
acknowledge incoming emergencies on MOTORBO lines. 

 Acknowledging MOTORBO emergencies no longer causes the console and parallel 
consoles to temporarily hang for two to three seconds.   

 GPS Trigger Button – The GPS Trigger button may now be configured as a global 
button (using selected line), and uses the correct GPS Trigger Time. 

 Post-PTT MDC-1200 ANIs are now shown correctly on the Select buttons of MTRBi 
lines.  

 Fixed issue which would cause the MOTORBO mobile radio to lock up during rapid 
key ups/PTTs from C-Soft.   

 Improved the MOTOTRBO history tab to look like the P25-DFSI tab. 
 Google Earth Fly on Read was added for MOTOTRBO Window in the Unit Control 

Tab.   
 Select Fly on Read to go to a specific location only when GPS Read is 

clicked on. 
 If Fly on Read is unchecked, the screen in C-Soft will fly to that location 

anytime a GPS update comes into C-Soft (i.e. when GPS Trigger is turned 
on).  

 Standardized how the Google Earth window is updated after receiving emergencies 
on lines configured for either MTRBi or MOTOTRO Interface. 

 Fixed a bug causing the Google Earth GPS interface to not work correctly after 
renaming the CSoftRuntime.exe executable file to a different file name. 

 Added ability to select which IDs are shown on Google Earth.  A list of available 
User IDs are displayed in MOTOTRBO Window  Selecting the check box next to the 
User IDs will enable that user to be displayed in Google Earth. 
 

 NENA 
 Fixed issue where NENA mute would become stuck in the muted state if a NENA 

line went on-hook during a call. 
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 Added “Mute NENA on PTT” option to the ADHB-4 Global Control.  When checked, 
this option will automatically mute the NENA line’s audio when the console 
transmits. 
 

 P25-DFSI 
 Increased the number of supported parallel console positions from 10 to 12. 
 P25-DFSI now supports Annunciation, PTT Talkback, and Per Line Intercom. 
 Removed the Emergency Acknowledge button from the P25-DFSI window’s History 

tab. 
 Clicking the Active Emergency window's Clear button will now properly clear and not 

acknowledge incoming emergencies on P25-DFSI lines. 
 The Popup window option “Open on Activity” now works correctly on P25-DFSI 

lines. 
 C-Soft now properly closes in the case where a P25-DFSI button is present in the 

.veg file, but no P25-DFSI lines are enabled. 
 Instant PTTs requiring a channel change now works correctly for P25- DFSI lines. 
 P25-DFSI changing from P25 to Analog in Mixed Mode with channel change has 

been fixed. 
 Added start of stream data to analog voice packets 

 
 Paging 

 Pages which are being actively sent now display the Paging icon on the button.  The 
Paging icon is displayed on Page, Manual Page, and Programmed Page Stack 
buttons. 

 Fixed issue in which DTMF Pagers containing between 11 and 16 characters in the 
DTMF string would not be sent correctly. 
 

 Per Line Call History Window 
 Incoming Group Calls on Telex Serial Line now properly display status of “Group 

Call” rather than “Select Call” 
 Fixed issue where after receiving a call with ANI information, future calls without ANI 

information would never be added to the Per Line Call History window. 
 Lines configured with a signaling type of Telex-Serial (formerly Kenwood-Serial) now 

display the correct Calling ID alias in Per Line Call History Window. 
 Resolved issue which caused blank entries to be added to the Per Line Call History 

window during calls which had ANI.  
 

 Signaling 
 Lines configured for the signaling type Telex-Serial now supports sending outgoing 

statuses with a status ID of up to 8 digits/characters. 
 Fixed issue which caused NXDN ANIs to disappear from the Select button during a 

call.  This problem occurred only if the Sticky ANI in Global Parameters Setup-
>Appearance was enabled. 

 Call Entries in the Per Line Call History windows which were specifically to the 
console were not being colored with the specified Call to Console color.  

 The Display All Call option was not being observed by all signaling types. 
 Radio Enable, Radio Disable, Private Call, and Group Call radio operations now 

support Fleetsync signaling. 
 Select Call, Status Request, Send Status, Remote Monitor, Private Call, and Group 

Call radio operations now supported on lines configured for a signaling type of Telex 
Serial. 
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 SIP  
 The full SIP URL (i.e. sip:212@172.19.100.14) is no longer displayed on the SIP 

Call Control button or the SIP Window.  Only the extension number is now 
displayed.  

 Added ability to hang up SIP Phone Call, accessible via right clicking a SIP Call 
Control button while a call is active. 

 Changed SIP Window tab order by moving the Forward tab before the Misc tab. 
 Resolved issue where console would infrequently crash when hanging up a call 

where the call was on hold and the console had two connections active on the same 
line. 
 

 VU Meter 
 Resolved issue where if a Per Line VU Meter was present in the .veg file, receive 

and transmit audio would be interrupted during a Relay button operation. 
 

5. Known Issues 
Version 6.500 
 C-Soft can only receive a text message from a MOTOTRBO radio using the MTRBi  Interface when 

a text message is sent from C-Soft and the remote radio is replying to that text message. 
 If multiple emergencies are active on a single MOTOTRBO line, acknowledging one of the 

emergencies will incorrectly stop the emergency indication actions (i.e. Select button blinking) on 
parallel consoles.   

 
6. Compatibility 

Version 6.500 
 Compatible with ADHB-4 Version 2.200 
 Compatible with IP-224 Version 1.300. 

 
 

7. Installation and Upgrade 
Version 6.500 
 To install C-Soft on Windows 7: 

 Double click on the C-Soft_7_xxbit setup executable.   
 Select the 32-bit executable if running the 32-bit version of Windows 7. 
 Select the 64-bit executable if running the 64-bit version of Windows 7. 

 Follow the steps in the installation instructions. 
 At the end of C-Soft installation, the user will be prompted to install the Sentinel SuperPro 

License Key Driver. 
 Complete the extra step for installing the Sentinel SuperPro License Key Driver. 
 When connecting the ADHB-4 the computer, the AHDB-4 driver will automatically installed. 

 
 To install C-Soft on Windows XP: 

 Double click on the C-Soft_XP setup executable 
 Follow the steps in the installation instructions. 
 At the end of C-Soft installation, the user will be prompted to install the Sentinel SuperPro 

License Key Driver. 
 When connecting the ADHB-4 to the computer, the user must select the location of the driver 

to install.  The driver is located at “C:\Program Files\Telex Communications\C-
Soft\usb_drivers”. 
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 To upgrade C-Soft: 

 Install C-Soft using the installation instructions 
- OR -  

 If the installation program has been ran previously, the new Runtime and Designer 
executables can be copied over the previous version in the C-Soft application folder. 


